Project

General

Profile

Actions

Bug #7270

closed

mdb can die on divide overflow

Added by Robert Mustacchi almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
mdb - modular debugger
Start date:
2016-08-03
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The following will kill mdb:

> 0x8000000000000000%-1=E
Arithmetic Exception (core dumped)

The problem is that mdb is not properly handling divide overflow; this case should be checked for explicitly and handled.

Actions #1

Updated by Electric Monk almost 5 years ago

  • Status changed from New to Closed

git commit 7df3beae80fb29626950d633c57d859c12563bc8

commit  7df3beae80fb29626950d633c57d859c12563bc8
Author: Bryan Cantrill <bryan@joyent.com>
Date:   2016-08-23T04:37:14.000Z

    7270 mdb can die on divide overflow
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Patrick Mooney <patrick.mooney@joyent.com>
    Reviewed by: Jason King <jason.brian.king@gmail.com>
    Approved by: Gordon Ross <gordon.w.ross@gmail.com>

Actions

Also available in: Atom PDF