Project

General

Profile

Actions

Bug #7284

closed

Remove unnecessary gender-specific pronouns from OS comments

Added by DJ Hoffman about 5 years ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Start date:
2016-08-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

illumos, due to the code base's long and storied history, contains many gender specific pronouns that refer to users, libraries, and even sections of code as "he". We felt this is unnecessarily exclusive and have evidence from within Delphix that this is something that people are bothered by. We are going through and replacing instances of gendered pronouns with "it" for non-sentient antecedents or other phrasing for humans, often using the singular "they".


Related issues

Is duplicate of illumos gate - Bug #7812: Remove gender specific languageClosedPrakash Surya2017-01-27

Actions
Actions #1

Updated by Dan McDonald 2 months ago

Closing this as a duplicate of #7812 which was integrated.

Actions #2

Updated by Dan McDonald 2 months ago

  • Is duplicate of Bug #7812: Remove gender specific language added
Actions #3

Updated by Dan McDonald 2 months ago

  • Status changed from Feedback to Duplicate
Actions

Also available in: Atom PDF