Project

General

Profile

Actions

Bug #7309

closed

CPU load is not shown in mate-system-monitor

Added by Alexander Pyhalov over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-08-16
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Launch mate-system-monitor. Wait for a while. You'll see graphs for memory and network consumption, but not for CPU load.

Actions #1

Updated by Alexander Pyhalov over 5 years ago

glibtop_get_sysinfo()->ncpu is 0, this is the reason of the issue

Actions #2

Updated by Alexander Pyhalov over 5 years ago

  • Status changed from New to Resolved

The issue is that libgtop support for Solaris is broken. As well as Sun/Oracle patch, which efficiently doesn't initialize sysinfo structure. As result, we receive 0 CPUs. Should be fixed by https://github.com/OpenIndiana/oi-userland/pull/2344

Actions

Also available in: Atom PDF