Project

General

Profile

Bug #7326

Problems with ssh package when upgrading from 15798 to 15818 upgrade failed for etc/ssh/sshd_config TypeError: 'NoneType' object is not callable

Added by Thomas Mieslinger over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
2016-08-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After manually resolving #7325 I run the update again and see the following error:

GeƤnderte Aktionen werden aktualisiert 4374/6209Action upgrade failed for 'etc/ssh/sshd_config' (pkg://openindiana.org/service/network/ssh):
TypeError: 'NoneType' object is not callable

The running system has not been modified. Modifications were only made to a clone of the running system. This clone is mounted at /tmp/tmpL3Qj5Z should you wish to inspect it.
Traceback (most recent call last):
File "/bin/pkg", line 5444, in handle_errors
__ret = func(*args, **kwargs)
File "/bin/pkg", line 5430, in main_func
pargs=pargs, **opts)
File "/bin/pkg", line 2116, in update
display_plan_cb=display_plan_cb, logger=logger)
File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1600, in _update
logger=logger)
File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1476, in __api_op
ret = __api_execute_plan(_op, _api_inst)
File "/usr/lib/python2.7/vendor-packages/pkg/client/client_api.py", line 1028, in __api_execute_plan
api_inst.execute_plan()
File "/usr/lib/python2.7/vendor-packages/pkg/client/api.py", line 2825, in execute_plan
self._img.imageplan.execute()
File "/usr/lib/python2.7/vendor-packages/pkg/client/imageplan.py", line 4613, in execute
p.execute_update(src, dest)
File "/usr/lib/python2.7/vendor-packages/pkg/client/pkgplan.py", line 582, in execute_update
dest.install(self, src)
File "/usr/lib/python2.7/vendor-packages/pkg/actions/file.py", line 189, in install
stream = self.data()
TypeError: 'NoneType' object is not callable

pkg: This is an internal error in pkg(5) version 33d20ff. Please log a
Service Request about this issue including the information above and this
message.

#1

Updated by Alexander Pyhalov over 4 years ago

  • Status changed from New to Closed
  • Assignee set to Alexander Pyhalov
  • Target version set to Hipster

Duplicate of #7325

Also available in: Atom PDF