Project

General

Profile

Bug #7429

workaround USB always identified as xHCI after latest ACPI update

Added by Robert Mustacchi about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
kernel
Start date:
2016-09-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

After we updated to the latest ACPI code (v6), some external users report that their USB keyboards no longer work. We suspect this is because they are being handled as xHCI devices (which we don't have a driver for yet) instead of as eHCI. We have verified that the temporary fix of disabling the newer Windows releases in the ACPI code will cause the problematic HW to revert to the desired eHCI driver. Once we have a working xHCI driver we can re-enable those Windows releases.

The problem is that the ACPI tables end up having logic where by if they detect a newer Windows version (as declared by the acpica common code), the ACPI code then automatically reroutes the USB ports to the xhci controller (a feature on various Intel chipsets).

History

#1

Updated by Electric Monk about 3 years ago

  • Status changed from New to Closed

git commit 7b1019a6d29ccb7999dc76cba3dde1c627e8e609

commit  7b1019a6d29ccb7999dc76cba3dde1c627e8e609
Author: Jerry Jelinek <jerry.jelinek@joyent.com>
Date:   2016-10-13T20:50:10.000Z

    4498 update to ACPI version 6.x
    7428 Deliver the ACPI debugging tools
    7429 workaround USB always identified as xHCI after latest ACPI update
    Reviewed by: Patrick Mooney <patrick.mooney@joyent.com>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Reviewed by: Gordon Ross <gwr@nexenta.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF