Project

General

Profile

Bug #743

oi_148 hangs after memory check when booting from live CD or live USB image

Added by Andrei Calin over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2011-02-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Greetings.

I have been trying to install OpenIndiana on my system for the past couple of days, and I've been confronted with this bug. I've done all the research I could before reporting this as a bug.

I've booted the kernel with the -v option, and it appears that it hangs after the memory check. I've tried to replicate the bug in a Virtual Box, but I haven't been successful in any way. I'll try to give as many details as possible.

The kernel hangs after the following output:
mem = [amount of memory] ([amount of memory in hex])

This happens very early in the booting process, specifically before the BIOS information is loaded (I've checked this with the -v output of the kernel boot on the virtual machine). This makes me believe it is a BIOS problem, somehow.

I've checked the Sun Hardware Compatibility list, and my motherboard and chipset are supported. The processor is not specifically mentioned, however (the i7 980x).

I had some Hard Drives in RAID on the machine. I've unplugged them, and I've disabled AHCI on all SATA controllers, because I had read that AHCI sometimes causes problems (like infinite reboots). I've only left one Hard Drive - the one I'm planning to install OpenIndiana on - plugged, and the problem didn't go away.

I've also read reports of mentioned USB controller malfunctions, but I believe the kernel hangs before any drivers are loaded. It couldn't be a driver issue. To be sure, I disabled my USB controllers, however, the kernel kept hanging after the memory check.

Also, if this is of any use, I've created live USB images both from Windows and Linux, and the live CD was created from Windows.

Could this be a hardware issue? Or a BIOS configuration problem?

History

#1

Updated by Andrei Calin over 8 years ago

There's one thing I forgot to mention: snv_134 produces the same behavior on my system. I've also tried to boot the live image without any hard drives connected, both with oi_148 and snv_134 and the problem still appears.

#2

Updated by Ken Mays over 8 years ago

  • Status changed from New to Feedback

Test hardware with Solaris 11 Express 2010.11 Live CD and provide feedback.

#3

Updated by Ken Mays over 8 years ago

Resolved. oi_148b worked as reliably in this case as Sol11x.

#4

Updated by Julian Wiesener over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF