Project

General

Profile

Bug #7439

libsqlite always rebuilds after illumos 6648

Added by Gordon Ross almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
tools - gate/build tools
Start date:
2016-09-30
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Steps to Reproduce:
cd $SRC/lib/libsqlite ; make
Expected Results:
everything up-to-date, no action.
Actual Results:
rebuilds every time.

History

#1

Updated by Gordon Ross almost 4 years ago

The reason this happens is that CFLAGS is an inherited macro that's set differently (via conditional assignment involving PICFLAGS) when we're building hte pic/*.o library objects vs. building the lint libraries etc.

Before #6648 was fixed, this makefile omitted CFLAGS, which masked this problem.
Have a fix which prevents PICFLAGS inheritance when building the "lemon" tool.

#2

Updated by Electric Monk almost 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 26649ed7fe1dcfc729f525f272ceefa8e2bfca34

commit  26649ed7fe1dcfc729f525f272ceefa8e2bfca34
Author: Gordon Ross <gwr@nexenta.com>
Date:   2016-10-03T12:55:14.000Z

    7439 libsqlite always rebuilds after illumos 6648
    Reviewed by: Yuri Pankov<yuri.pankov@nexenta.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Dan McDonald <danmcd@omniti.com>

Also available in: Atom PDF