Project

General

Profile

Bug #7470

acpi build sometimes doesn't descend into SUBDIRS

Added by Robert Mustacchi about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
cmd - userland programs
Start date:
2016-10-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Experimentally, we've seen some vexing behavior from dmake that most often manifests itself when performing a multi-proto build. Specifically, we saw that dmake sometimes doesn't descend into the subdirs of cmd/acpi, but does descend into common. In theory this should always happen because in cmd/acpi/Makefile, $(SUBDIRS) depends on common which depends on FRC. Because we should always in theory rebuild common due to FRC, we should also therefore rebuild the $(SUBDIRS).

For some reason, this isn't happening. In addition, whenever debugging with the -d or -dd flags is enabled, dmake then of course does the right thing. In the interim, to stop breaking folks who are using the multi-proto build, we should add an extra FRC dependency on the $(SUBDIRS) target.

History

#1

Updated by Electric Monk about 4 years ago

  • Status changed from New to Closed
  • % Done changed from 90 to 100

git commit a1964bdd47804c37e09db1a79c23937c9aeac165

commit  a1964bdd47804c37e09db1a79c23937c9aeac165
Author: Robert Mustacchi <rm@joyent.com>
Date:   2016-10-14T22:28:19.000Z

    7470 acpi build sometimes doesn't descend into SUBDIRS
    Reviewed by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF