Project

General

Profile

Bug #7487

ld failed on sparc with relocation

Added by Igor Kozhukhov almost 3 years ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2016-10-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

igork@bld13:~/builds/igork/dg-54$ ~/ld.sh 
Build type   is  DEBUG
RELEASE      is 
VERSION      is 1.3.7-D
RELEASE_DATE is October-21-2016

setup: closedbins bldtools sgs mapfiles
The top-level 'setup' target is available to build headers and tools.

newtask: user "igork" is not a member of project "system" 
Using /bin/bash as shell.
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/capabilities
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/capabilities/sun4u
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/capabilities/sun4u/sparcv9
/usr/bin/ld -64 -r -o pics/objcap.o -M../common/mapfile-cap -Breduce pics/md5.o pics/sha1.o pics/sha1_asm.o
/usr/bin/ld -64 -r -o pics/symcap.o -z symbolcap pics/objcap.o
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/capabilities/sun4v
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/capabilities/sun4v/sparcv9
/export/home/igork/builds/igork/dg-54/usr/src/lib/libmd/sparcv9
/ws/builds/igork/dg-54/usr/src/tools/proto/root_sparc-nd/opt/onbld/bin/sparc/cw -_gcc -xO3 -m64 -dalign -v  -Wc,-Qiselect-regsym=0  -Wc,-Qassembler-ounrefsym=0 -xspace -W0,-Lt -Xa  -xildoff -errtags=yes -errwarn=%all -erroff=E_EMPTY_TRANSLATION_UNIT -erroff=E_STATEMENT_NOT_REACHED -_gcc=-Wno-missing-braces -_gcc=-Wno-sign-compare -_gcc=-Wno-unknown-pragmas -_gcc=-Wno-unused-parameter -_gcc=-Wno-missing-field-initializers -_gcc=-Wno-array-bounds -xc99=%none -Wd,-xsafe=unboundsym -W2,-xwrap_int  -W0,-xglobalstatic -_gcc=-fno-inline-small-functions  -_gcc=-fno-inline-functions-called-once  -_gcc=-fno-ipa-cp -_gcc=-fno-ipa-sra    -v -o libmd.so.1 -G -hlibmd.so.1 -ztext -zdefs -Bdirect  -M../common/mapfile-vers -M/ws/builds/igork/dg-54/usr/src/common/mapfiles/common/map.pagealign   pics/edonr.o pics/md4.o pics/md5.o pics/sha1.o pics/sha2.o  pics/skein.o pics/skein_block.o pics/skein_iv.o ../capabilities/sun4u/sparcv9/pics/symcap.o  ../capabilities/sun4v/sparcv9/pics/symcap.o  -L/ws/builds/igork/dg-54/proto/root_sparc/lib/sparcv9 -L/ws/builds/igork/dg-54/proto/root_sparc/usr/lib/sparcv9      -lc
+ /usr/gcc/5/bin/gcc -fident -finline -fno-inline-functions -fno-builtin -fno-asm -fdiagnostics-show-option -nodefaultlibs -mno-integer-ldd-std -D__sun -fno-strict-aliasing -fno-unit-at-a-time -fno-optimize-sibling-calls -O2 -m64 -Wall -Wextra -Werror -Wno-missing-braces -Wno-sign-compare -Wno-unknown-pragmas -Wno-unused-parameter -Wno-missing-field-initializers -Wno-array-bounds -std=gnu89 -fno-inline-small-functions -fno-inline-functions-called-once -fno-ipa-cp -fno-ipa-sra -o libmd.so.1 -shared -hlibmd.so.1 -Wl,-ztext -Wl,-zdefs -Wl,-Bdirect -Wl,-M../common/mapfile-vers -Wl,-M/ws/builds/igork/dg-54/usr/src/common/mapfiles/common/map.pagealign pics/edonr.o pics/md4.o pics/md5.o pics/sha1.o pics/sha2.o pics/skein.o pics/skein_block.o pics/skein_iv.o ../capabilities/sun4u/sparcv9/pics/symcap.o ../capabilities/sun4v/sparcv9/pics/symcap.o -L/ws/builds/igork/dg-54/proto/root_sparc/lib/sparcv9 -L/ws/builds/igork/dg-54/proto/root_sparc/usr/lib/sparcv9 -lc -mcpu=v9 
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4u/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4u/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4u/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4u/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4u/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4v/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4v/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
ld: warning: relocation warning: R_SPARC_WPLT30: file ../capabilities/sun4v/sparcv9/pics/symcap.o: section [21].rela.text: symbol __sparc_get_pc_thunk.l7: relocation against discarded COMDAT section [4].text.__sparc_get_pc_thunk.l7: symbol not found, relocation ignored
/usr/bin/rm -f /ws/builds/igork/dg-54/proto/root_sparc/lib/sparcv9/libmd.so.1; /usr/bin/install  -m 755 -t /ws/builds/igork/dg-54/proto/root_sparc/lib/sparcv9 libmd.so.1       

Related issues

Related to illumos gate - Bug #6094: SPARC: gcc48 build: ld: warning: relocation warning: R_SPARC_WPLT30Closed2015-08-01

Actions
Related to illumos gate - Bug #10346: ld(1) should not reduce symbol visibility of COMDAT symbols when producing relocatable objectsClosed2019-02-05

Actions

History

#2

Updated by Igor Kozhukhov almost 3 years ago

  • Related to Bug #6094: SPARC: gcc48 build: ld: warning: relocation warning: R_SPARC_WPLT30 added
#3

Updated by Rich Lowe 8 months ago

  • Related to Bug #10346: ld(1) should not reduce symbol visibility of COMDAT symbols when producing relocatable objects added
#4

Updated by Rich Lowe 5 months ago

  • Status changed from New to Closed

Actually a duplicate of #6094, not just related

Also available in: Atom PDF