Project

General

Profile

Bug #7508

panic during boot due to mixed MWAIT support

Added by Robert Mustacchi about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2016-10-25
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Reported by dkasza via IRC and GH:

    One of my computers cannot boot the stock SmartOS platform images.

    Lenovo ThinkStation E30, Xeon E3-1235
    Panic message: unsupported mixed cpu monitor/mwait support detected

    OmniOS, and OpenIndiana fail to boot with the same message. It appears that the boot CPU does not report mwait capability (disabled by BIOS maybe?), but the other CPUs do.

    The computer is stable with only one core enabled.

    The computer is also stable with this patch and all cores enabled.
    Note that the new condition matches the comment that was originally there. The computer still prints warnings about the feature mismatch.

It's very strange that the boot CPU is reporting MWAIT support which differs from the other cores. At the very least, we should be able to handle this situation by disabling MWAIT across the other cores. It would be ideal if we can get to the root cause of why this is different in the first place.


There exists a small subset of systems which expose differing
MWAIT/MONITOR support between CPUs. If MWAIT support is absent from
the boot CPU, but is found on a later CPU, the system continues to
operate as if no MWAIT support is available.

The reverse case, where MWAIT is available on the boot CPU but not
on a subsequently initialized CPU, is not presently allowed and will
result in a panic.

#1

Updated by Electric Monk about 4 years ago

  • Status changed from New to Closed

git commit 4d4b495364f064247d3365e7dfa1da1b47cb3bd8

commit  4d4b495364f064247d3365e7dfa1da1b47cb3bd8
Author: Patrick Mooney <pmooney@pfmooney.com>
Date:   2016-11-17T02:57:52.000Z

    7508 panic during boot due to mixed MWAIT support
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Approved by: Dan McDonald <danmcd@omniti.com>

Also available in: Atom PDF