Project

General

Profile

Bug #7597

lightdm switches console to VT1 too early

Added by r a almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-11-20
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

When I use the shutdown command as "shutdown -is -g0 -y" or "shutdown -iS -g0 -y" the host starts the shutdown process, the console clears but the host never enters single user mode.
I have also "init S" or "init s" but that also fails to take the host into single user mode.

History

#1

Updated by r a almost 3 years ago

r a wrote:

When I use the shutdown command as "shutdown -is -g0 -y" or "shutdown -iS -g0 -y" the host starts the shutdown process, the console clears but the host never enters single user mode.
I have also "init S" or "init s" but that also fails to take the host into single user mode.

My host is running the latest update of OpenIndiana Hipster 2016.10, illumos-970db7b as reported by uname -a

#2

Updated by Alexander Pyhalov almost 3 years ago

Does host run Xorg?

#3

Updated by Alexander Pyhalov almost 3 years ago

If I understand it correctly (applying my telepathic skills), the issue is that on 'svcadm disable lightdm' lightdm doesn't restore console text mode. This is related to the fact that it activates VT0 before shutting down Xorg. And so Xorg has chance to intervene on shutdown. So, lightdm should switch console to VT0 later, after Xorg is already down.

#4

Updated by Alexander Pyhalov almost 3 years ago

  • Subject changed from shutdown -iS -g0 -y does not permit entry into single user mode to lightdm switches console to vt0 too early
#5

Updated by Alexander Pyhalov almost 3 years ago

  • Subject changed from lightdm switches console to vt0 too early to lightdm switches console to VT1 too early
#6

Updated by Alexander Pyhalov almost 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF