Project

General

Profile

Actions

Bug #7626

closed

PPGTT setup problem

Added by Toomas Soome about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Start date:
2016-11-27
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Nov 27 19:53:14 beastie drm: [ID 694095 kern.warning] WARNING: [drm:i915_ppgtt_page_alloc:156] drm_gem_object_alloc: ddi_dma_mem_alloc failed
Nov 27 19:53:14 beastie drm: [ID 859051 kern.warning] WARNING: [drm:i915_gem_init_global_gtt:709] Aliased PPGTT setup failed -12

Actions #1

Updated by Toomas Soome about 5 years ago

Toomas Soome wrote:

Nov 27 19:53:14 beastie drm: [ID 694095 kern.warning] WARNING: [drm:i915_ppgtt_page_alloc:156] drm_gem_object_alloc: ddi_dma_mem_alloc failed
Nov 27 19:53:14 beastie drm: [ID 859051 kern.warning] WARNING: [drm:i915_gem_init_global_gtt:709] Aliased PPGTT setup failed -12

display (pciex8086,41a) [Intel Corporation Xeon E3-1200 v3 Processor Integrated Graphics Controller], instance #0 (driver name: i915)

Actions #2

Updated by Gordon Ross about 5 years ago

I suspect this might fix it:

diff --git a/usr/src/uts/intel/io/i915/i915_gem_gtt.c b/usr/src/uts/intel/io/i915/i915_gem_gtt.c
index 83fbac7..ab81ea5 100644
--- a/usr/src/uts/intel/io/i915/i915_gem_gtt.c
+++ b/usr/src/uts/intel/io/i915/i915_gem_gtt.c
@@ -112,7 +112,7 @@ static gen6_gtt_pte_t hsw_pte_encode(struct drm_device *dev,

 static ddi_dma_attr_t ppgt_dma_attr = {
     DMA_ATTR_V0,
-    0xff000U,             /* dma_attr_addr_lo */
+    0,                 /* dma_attr_addr_lo */
     0xffffffffU,            /* dma_attr_addr_hi */
     0xffffffffU,            /* dma_attr_count_max */
     4096,                /* dma_attr_align */

Actions #3

Updated by Toomas Soome about 5 years ago

Gordon Ross wrote:

I suspect this might fix it:
[...]

It seems so, I did patch with mdb -kw, and after this there are no more of those warnings when X is started.

Actions #4

Updated by Gordon Ross about 5 years ago

OK, so the fix above is confirmed. BTW, this is caused by #7634
For the near term, it appears we can get away setting addr_lo = 0.
Once 7634 is fixed, we should come back to this and set
addr_lo = 1M for all the DMA allocations done for DRM.

Actions #5

Updated by Gordon Ross about 5 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF