Project

General

Profile

Actions

Feature #7661

closed

illumos should provide 64bit perl modules

Added by Andrew Stormont over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
2016-12-11
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

My Omni bloody install which I use for integration testing hasn't been working right for a while. It seems the system version of perl is 64bit, but the modules installed by illumos are 32bit. An option to build 64bit modules as well would solve this issue.


Related issues

Related to illumos gate - Bug #7170: ENABLE_PERL64 multiarch buildsClosed2016-07-05

Actions
Related to illumos gate - Bug #11763: Build can't find perl on OI HipsterClosedAndrew Stormont

Actions
Actions #2

Updated by Andrew Stormont almost 3 years ago

  • Related to Bug #7170: ENABLE_PERL64 multiarch builds added
Actions #4

Updated by Electric Monk almost 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

git commit 0ae9a84f82e18b30b7354ca5193afdbbb1cdc880

commit  0ae9a84f82e18b30b7354ca5193afdbbb1cdc880
Author: Andrew Stormont <astormont@racktopsystems.com>
Date:   2019-09-27T22:36:30.000Z

    7661 illumos should provide 64bit perl modules
    Reviewed by: Andy Fiddaman <andy@omniosce.org>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Approved by: Dan McDonald <danmcd@joyent.com>

Actions #5

Updated by Andrew Stormont almost 3 years ago

  • Related to Bug #11763: Build can't find perl on OI Hipster added
Actions #6

Updated by Joshua M. Clulow over 2 years ago

Note that this and #11763 appear to constitute a flag day. If you see these errors in nightly.log:

     /usr/perl5/5.22/bin/i386/perl /usr/perl5/5.22/lib/ExtUtils/xsubpp
-typemap /usr/perl5/5.22/lib/ExtUtils/typemap  Intrs.xs >i386/Intrs.c
    sh: line 1: /usr/perl5/5.22/bin/i386/perl: not found
    *** Error code 127
    ...
    sh: line 1: /usr/perl5/5.22/bin/amd64/perl: not found
    ...

You'll need to add export BUILDPERL64="#" to your environment file.

Actions

Also available in: Atom PDF