Project

General

Profile

Bug #7678

smbsrv: Memory leak on module unload

Added by Marcel Telka about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
cifs - CIFS server and client
Start date:
2016-12-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

On smbsrv module unload the current_codepage is leaked:

kmem_oversize leak: 1 vmem_seg, 393256 bytes
            ADDR TYPE            START              END             SIZE
                                THREAD        TIMESTAMP                 
ffffff01cb59c8c8 ALLC ffffff01d9422000 ffffff01d9482028           393256
                      ffffff0004d16c40      e19e9d70659
                 vmem_hash_insert+0xae
                 vmem_seg_alloc+0x23e
                 vmem_xalloc+0x749    
                 vmem_alloc+0x145     
                 kmem_alloc+0x11a     
                 kmem_zalloc+0xed     
                 smbsrv`smb_alloc+0x35
                 smb_mem_zalloc+0x1b  
                 smb_unicode_init+0xe 
                 smb_codepage_init+0x15
                 smb_server_g_init+0x42
                 _init+0xd            
                 modinstall+0x113     
                 mod_hold_installed_mod+0x77
                 modrload+0xdd        
                 modload+0x17         
                 mod_hold_dev_by_major+0xbf
                 ndi_hold_driver+0x30 
                 probe_node+0x52      
                 i_ndi_config_node+0x110

Steps to reproduce: Load and unload the smbsrv kernel module.


Related issues

Is duplicate of illumos gate - Bug #8062: memory leak in smb_unicode_init()Closed2017-04-13

Actions

History

#1

Updated by Marcel Telka almost 3 years ago

  • Is duplicate of Bug #8062: memory leak in smb_unicode_init() added
#2

Updated by Marcel Telka almost 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF