Project

General

Profile

Bug #7693

pynfs: OPEN4 st_open.testCreatExclusiveFile FAILURE

Added by Vitaliy Gusev over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
nfs - NFS server and client
Start date:
2016-12-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

NFSv4 compatibility testing.

During testing nfs4 server via running pynfs testing tool:

./testserver.py 192.168.5.152:/codepool/data --force --nocleanup OPEN4

******************************************
OPEN4 st_open.testCreatExclusiveFile : FAILURE
Trying to do exclusive recreate of file OPEN4 should
return NFS4_OK, instead got NFS4ERR_EXIST ******************************************
Command line asked for 1 of 662 tests
Of those: 0 Skipped, 1 Failed, 0 Warned, 0 Passed


Files

open4.pcap (6.25 KB) open4.pcap captured traffic between client and server Vitaliy Gusev, 2016-12-27 07:39 PM

History

#1

Updated by Vitaliy Gusev over 3 years ago

The issue is in that "timespec32_t *mtime" passed to create_vnode() is just casted raw value of createverf. And passed "mtime" is not the same as vap->va_mtime.

#2

Updated by Vitaliy Gusev over 3 years ago

OPEN request with create-mode EXCLUSIVE4 should return NFS4_OK if :
- file created successfully
- file exists and create timestamp is the same as "createverf"

#3

Updated by Electric Monk over 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 77e6f23f311b4352dcc27ce2fcbd2c06546ce837

commit  77e6f23f311b4352dcc27ce2fcbd2c06546ce837
Author: Vitaliy Gusev <gusev.vitaliy@gmail.com>
Date:   2017-01-16T16:35:32.000Z

    7693 pynfs: OPEN4 st_open.testCreatExclusiveFile FAILURE
    Reviewed by: Andrew Stormont <andyjstormont@gmail.com>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Marcel Telka <marcel@telka.sk>
    Approved by: Dan McDonald <danmcd@omniti.com>

Also available in: Atom PDF