Project

General

Profile

Bug #7695

loader btxldr: process all PT_LOAD segments, not just the first two

Added by Toomas Soome over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
bootloader
Start date:
2016-12-28
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Update from FreeBSD:

With default settings GNU ld generates two PT_LOADs for loader.sym while
LLD generates three, because it creates a rodata segment. Previously
btxldr terminated phdr processing after two PT_LOADs. Remove the early
termination to process all PT_LOADs.

https://svnweb.freebsd.org/base?view=revision&revision=310702

Since we build with GNU ld, the issue is not affecting our build at this time, but it is good cleanup for future in any case.

History

#1

Updated by Electric Monk over 3 years ago

  • % Done changed from 90 to 100
  • Status changed from New to Closed

git commit 92f29c4ad7c40b844424bb1858c06f2baea67ddd

commit  92f29c4ad7c40b844424bb1858c06f2baea67ddd
Author: Toomas Soome <tsoome@me.com>
Date:   2017-01-05T10:06:44.000Z

    7695 loader btxldr: process all PT_LOAD segments, not just the first two
    Reviewed by: Rich Lowe <richlowe@richlowe.net>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Approved by: Hans Rosenfeld <rosenfeld@grumpf.hope-2000.org>

Also available in: Atom PDF