Project

General

Profile

Actions

Bug #7723

closed

disable MSI-X in nvme on VMware

Added by Hans Rosenfeld over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Category:
driver - device drivers
Start date:
2017-01-03
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage
Gerrit CR:

Description

At attach time the nvme driver sets up an initial interrupt, and a little later it disables it and sets up several MSI-X interrupts for all the queues. If the initial interrupt is also MSI-X this will confuse VMware ESXi enough to shut off the VM. This apparently happens only with NVMe devices in passthrough mode.

The problem is actually very likely a VMware bug: it notices that we set up the first MSI-X interrupt, but it doesn't understand that we're disabling it again. We can't fix VMware, but we can disable the use of MSI-X in nvme on VMware.


Related issues

Related to illumos gate - Bug #9566: Disabled MSI-X for NVMe passthrough on ESXi must be reverted because VMware fixed the bug on their endNew2018-05-30

Actions
Actions #1

Updated by Electric Monk over 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 9d08e1f8c231016dcfeb854acff457e0e54f179d

commit  9d08e1f8c231016dcfeb854acff457e0e54f179d
Author: Hans Rosenfeld <hans.rosenfeld@nexenta.com>
Date:   2017-01-10T09:48:14.000Z

    7723 disable MSI-X in nvme on VMware
    Reviewed by: Rick McNeal <rick.mcneal@nexenta.com>
    Reviewed by: Yuri Pankov <yuri.pankov@nexenta.com>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Approved by: Dan McDonald <danmcd@omniti.com>

Actions #2

Updated by Dan McDonald about 3 years ago

  • Related to Bug #9566: Disabled MSI-X for NVMe passthrough on ESXi must be reverted because VMware fixed the bug on their end added
Actions

Also available in: Atom PDF