Project

General

Profile

Bug #7739

zfs_inherit_003_pos fails due to improperly generated random strings

Added by Prakash Surya over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
zfs - Zettabyte File System
Start date:
2017-01-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The problem is that get_prop (in libtest.sh) does not faithfully print the
property value. It needs to enclose $prop_val in double-quotes.

History

#1

Updated by Electric Monk over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 0e93ddde309a21971dc41356b4834acecaeb9e20

commit  0e93ddde309a21971dc41356b4834acecaeb9e20
Author: Matthew Ahrens <mahrens@delphix.com>
Date:   2017-01-12T03:02:18.000Z

    7739 zfs_inherit_003_pos fails due to improperly generated random strings
    Reviewed by: John Kennedy <john.kennedy@delphix.com>
    Reviewed by: Prakash Surya <prakash.surya@delphix.com>
    Reviewed by: Pavel Zakharov <pavel.zakharov@delphix.com>
    Reviewed by: Yuri Pankov <yuri.pankov@gmail.com>
    Approved by: Robert Mustacchi <rm@joyent.com>

Also available in: Atom PDF