Project

General

Profile

Bug #7785

CIFS: smbd[9813]: [ID 491055 daemon.debug] share: failed to cache repo_name (2115)

Added by Manikandan Palanimuthu almost 3 years ago. Updated over 2 years ago.

Status:
New
Priority:
Urgent
Assignee:
-
Category:
-
Start date:
2017-01-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi Team,

I am running OmniOS version R151014. I have some 4 CIFS shares with different names shared across my network. Recently I planned to upgrade it to build R151018. My upgrade was successful, but unfortunately, all my shares are not visible and I am getting similar error for all the shares in syslog

smbd[9813]: [ID 491055 daemon.debug] share: failed to cache <repo_name>

Observation: I am able to create a new CIFS share with the command zfs set sharesmb=name=new_repo_name. Only old repo's are not visible. Please help me on this.

History

#1

Updated by Jason King over 2 years ago

I ran into the same error message. It turns out earlier (much earlier) versions of smbd had set some rather odd ACLs on the top-level share directory (as well all the files underneath it). Running 'chmod R A dir' and then resetting the sharesmb value (to itself) fixed the issue. It does seem to be misreporting the actual error.

#2

Updated by Yuri Pankov over 2 years ago

  • Description updated (diff)

Also available in: Atom PDF