Project

General

Profile

Actions

Bug #7797

closed

SMF service removal: metainit service fails to load on update

Added by Nikola M. over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
smf
Start date:
2017-01-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Metainit service is supposed to be removed as I am informed,
but it is still there and putting error after Openindiana hipster update. and that could point out ot SMF bug.

Jan 20 08:33:27 oi-h svc.startd10: [ID 652011 daemon.warning] svc:/system/metainit:default: Method "/lib/svc/method/svc-metainit" failed with exit status 127.
Jan 20 08:33:28 oi-h last message repeated 2 times
Jan 20 08:33:28 oi-h svc.startd10: [ID 748625 daemon.error] system/metainit:default failed: transitioned to maintenance (see 'svcs -xv' for details)

$ svcs -xv
svc:/system/metainit:default (SVM initialization)
State: maintenance since January 23, 2017 09:07:21 AM CET
Reason: Start method failed repeatedly, last exited with status 127.
See: http://illumos.org/msg/SMF-8000-KS
See: man -M /usr/share/man -s 1M metainit
See: /var/svc/log/system-metainit:default.log
Impact: This service is not running.

/var/svc/log/system-metainit:default.log attached.


Files

system-metainit_default.log (326 KB) system-metainit_default.log Nikola M., 2017-01-23 11:06 AM

Related issues

Is duplicate of illumos gate - Bug #7818: SMF does not always cleanup services that have been removedClosedAndrew Stormont2017-01-28

Actions
Actions #1

Updated by Andrew Stormont over 4 years ago

  • Is duplicate of Bug #7818: SMF does not always cleanup services that have been removed added
Actions #2

Updated by Electric Monk over 4 years ago

  • Status changed from New to Closed

git commit 56bce6093e5a50ce1da04e68f5e22a53c35cc8a8

commit  56bce6093e5a50ce1da04e68f5e22a53c35cc8a8
Author: Andrew Stormont <astormont@racktopsystems.com>
Date:   2017-02-06T23:11:06.000Z

    7818 SMF does not always cleanup services that have been removed
    Reviewed by: Joshua M. Clulow <josh@sysmgr.org>
    Approved by: Robert Mustacchi <rm@joyent.com>

Actions

Also available in: Atom PDF