Project

General

Profile

Bug #782

automake package does not install `automake`

Added by Matt Connolly over 8 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2011-03-08
Due date:
2011-09-14
% Done:

100%

Estimated time:
8.00 h
Difficulty:
Bite-size
Tags:
automake

Description

The package `developer/build/automake-110` does not install the `automake` or `aclocal` commands. (As those names, at least).

For example:
  1. pkg install developer/build/automakte-110
  2. automake
    ... not found error
It installs `/usr/bin/automake-1.10` and the user is required to do this:
  1. ln -s /usr/bin/automake-1.10 /usr/bin/automake
  2. ln -s /usr/bin/aclocal-1.10 /usr/bin/aclocal

to be able to use the commands in the expected manner.

Is it possible to update the package installer to create these symlinks?

Especially in the case where a user installs only one version of automake, there is no need to manually resolve the version.

History

#1

Updated by Matt Connolly over 8 years ago

Oops.. `#` command prompt prefixes turned into numbers.

#2

Updated by Julian Wiesener over 8 years ago

  • Assignee set to OI SFW

there are two automake versions pkg:/developer/build/automake-110 and pkg:. I suppose at least one version should ship a /usr/share/automake and /usr/bin/aclocal symlink to make autogen.sh work for most users with no change.

I would prefere 1.10.

#3

Updated by Alan Coopersmith over 8 years ago

Fixed "upstream" in the Userland packaging of automake-1.10 in snv_162.

#4

Updated by Ken Mays about 8 years ago

  • Due date set to 2011-09-14
  • Category set to 10
  • Assignee changed from OI SFW to OI Userland
  • Target version set to oi_151_stable
  • Estimated time set to 8.00 h
  • Difficulty set to Bite-size
  • Tags set to needs-triage
#5

Updated by Ken Mays about 8 years ago

  • Status changed from New to Closed
  • Tags changed from needs-triage to automake

Matt - as mentioned, we will pull the fix in from upstream during our next release cycle. Closing ticket.

#6

Updated by Albert Lee about 6 years ago

  • Status changed from Closed to New

This bug is not resolved.

#7

Updated by Ken Mays over 5 years ago

  • Status changed from New to Closed
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

,5.11-0.151.1.8.1:20131111T084033Z
,5.11-0.151.1.8.1:20131111T083958Z

Also available in: Atom PDF