Project

General

Profile

Actions

Bug #7868

closed

After pkg update (2017-02-13) keyboard doesn't work at lightdm prompt

Added by Will B almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-02-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After a clean install of OpenIndiana Hipster 2016.10, I immediately performed pkg refresh --full then pkg update.

After reboot, the USB keyboard no longer worked at the lightdm login prompt, although the USB mouse works. Clicking the username and password text boxes works as expected, and the GUI appears to be responsive and working. When I press the Ctrl + C keys at the lightdm prompt, lightdm disappears and I am dropped to a virtual terminal. A screenshot of the contents of the terminal are attached.

No changes were made to OpenIndiana except for updating it. Nothing was configured or installed except the base system.

This hardware works fine with Ubuntu, Debian, CentOS and other Linux distros. It also works well with FreeBSD 10.4 and 11.0.

This issue happens on both 'bare metal' as well as in a VirtualBox virtual-machine, Version 5.1.14 r112924.

Hardware information:
  • Intel Core(TM) i5-4590 CPU @ 3.30GHz
  • Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
  • PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
  • Communication controller: Intel Corporation 9 Series Chipset Family ME Interface #1
  • USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #2
  • Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
  • PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 (rev d0)
  • SATA controller: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode]
  • VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
  • Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

Files

VirtualBox_OpenIndiana_14_02_2017_14_23_45.png (15.4 KB) VirtualBox_OpenIndiana_14_02_2017_14_23_45.png Virtual terminal output after pressing Ctrl + C at lightdm prompt Will B, 2017-02-14 10:25 PM
oi-lightdm-log-2017-02-14.txt (4.27 KB) oi-lightdm-log-2017-02-14.txt /var/svc/log/application-graphical-login-lightdm:default.log Will B, 2017-02-14 10:49 PM
Actions #1

Updated by Will B almost 5 years ago

Just to clarify, the keyboard does work when in the virtual terminal / console, just not at the login lightdm prompt.

Actions #2

Updated by Will B almost 5 years ago

Adding the lightdm log

Actions #3

Updated by Will B almost 5 years ago

This issue appears to happen when the computer is shut down completely after installation then restarted, and also when the computer is shut down completely then restarted after the first pkg refresh and pkg update.

When 'fast reboot' is used instead of shutting down between steps, this problem does not seem to occur.

Actions #4

Updated by Alexander Pyhalov almost 5 years ago

It's likely related to https://www.illumos.org/issues/7866 . Check that you have installed.

Actions #5

Updated by Alexander Pyhalov almost 5 years ago

  • Project changed from illumos gate to OpenIndiana Distribution
Actions #6

Updated by Aurélien Larcher almost 5 years ago

I already talked with Will 2 days ago, the issue was indeed data-xkb.
He updated and got his keyboard back.

Actions #7

Updated by Will B almost 5 years ago

Aurélien Larcher wrote:

I already talked with Will 2 days ago, the issue was indeed data-xkb.
He updated and got his keyboard back.

Yes, thank you very much. Everything appears to be resolved at this point. :-D

Actions #8

Updated by Alexander Pyhalov almost 5 years ago

  • Status changed from New to Resolved

Duplicate of #7866

Actions

Also available in: Atom PDF