Project

General

Profile

Actions

Bug #7929

closed

PulseAudio doesn't detect hardware even though OSSv4 does

Added by Will B over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-03-03
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

When attempting to hear audio from Firefox or Thunderbird, nothing is heard and examining "Sound Preferences" (mate-volume-control) shows no recognized hardware. PulseAudio is running and all levels are set to good values.

I am using the integrated motherboard 3.5mm audio output (green jack). I am not using HDMI audio.

When using the "Multimedia Systems Selector" (gstreamer-properties) to select OSSv4, I can hear audio from all other apps except Thunderbird and Firefox.

The only mention of PulseAudio I see is in the following log file:

~/.xsession-errors

W: [(null)] caps.c: Normally all extra capabilities would be dropped now, but that's impossible because PulseAudio was built without capabilities support.
W: [(null)] caps.c: Normally all extra capabilities would be dropped now, but that's impossible because PulseAudio was built without capabilities support.

~/.audioctl/audioctl-will-oi-audiohd#0

# Device: /dev/sound/audiohd:0mixer
# Name    = audiohd#0
# Config  = onboard1 (a)
# HW Info = Unknown HD codec: 0x80862807
#
#CONTROL                 VALUE     
volume                   75       

~/.audioctl/audioctl-will-oi-audiohd#1

# Device: /dev/sound/audiohd:1mixer
# Name    = audiohd#1
# Config  = onboard1 (a)
# HW Info = Unknown HD codec: 0x10ec0892
#
#CONTROL                 VALUE     
volume                   75        
center                   75        
lfe                      75        
rear                     75:75     
surround                 75:75     
mic                      50:50     
line-in                  50:50     
front                    75:75     
headphones               75:75     
monitor-gain             0:0       
loopback                 off       
record-source            mic      

No hardware detected

Outputs listed

Actions #1

Updated by Will B over 4 years ago

I did find more information in dmesg:

Mar  2 21:37:06 will-oi audio: [ID 946290 kern.warning] WARNING: audiohd#0: timeout when get response from codec: wid=4, verb=0x0f02, param=0x0058
Mar  2 21:37:06 will-oi audio: [ID 946290 kern.warning] WARNING: audiohd#0: timeout when get response from codec: wid=4, verb=0x0f02, param=0x005a
[...]
Mar  2 21:37:06 will-oi npe: [ID 236367 kern.info] PCI Express-device: pci8086,2010@3, audiohd0
Mar  2 21:37:06 will-oi genunix: [ID 936769 kern.info] audiohd0 is /pci@0,0/pci8086,2010@3
Mar  2 21:37:06 will-oi npe: [ID 236367 kern.info] PCI Express-device: pci1458,a182@1b, audiohd1
Mar  2 21:37:06 will-oi genunix: [ID 936769 kern.info] audiohd1 is /pci@0,0/pci1458,a182@1b
[...]
Mar  2 21:37:54 will-oi pulseaudio[1693]: [ID 295310 user.error] [(null)] module-device-restore.c: Failed to open volume database '/home/will/.config/pulse/03601f186ff915b8ab31c92658b6238b-device-volumes': I/O error
Mar  2 21:37:54 will-oi pulseaudio[1693]: [ID 295310 user.error] [(null)] module.c: Failed to load module "module-device-restore" (argument: ""): initialization failed.
Mar  2 21:37:54 will-oi pulseaudio[1693]: [ID 295310 user.error] [(null)] main.c: Module load failed.
Mar  2 21:37:54 will-oi pulseaudio[1693]: [ID 295310 user.error] [(null)] main.c: Failed to initialize daemon.
Mar  2 21:37:54 will-oi pulseaudio[1684]: [ID 295310 user.error] [(null)] main.c: Daemon startup failed.

Regarding the permissions issue with ~/.config/pulse/, I did set the permissions as mentioned in issue #7820, but PulseAudio still would not play sound, and after logging out, then back in, the permissions are set back to too restrictive values.

Actions #2

Updated by Alexander Pyhalov over 4 years ago

  • Status changed from New to Rejected

Duplicate of #7479

Actions #3

Updated by Alexander Pyhalov over 4 years ago

A bit of clarification. It's not strictly a duplicate of #7479, but was very confusing when I started investigating what's wrong with #7479. Briefly, for Solarish platforms pulseaudio doesn't support device list. It just doesn't have means to enumerate/show any hardware devices. But it doesn't mean that it doesn't work for setting basic device properties generally for pulseaudio or for /dev/dsp.

Actions #4

Updated by Will B over 4 years ago

Alexander Pyhalov wrote:

A bit of clarification. It's not strictly a duplicate of #7479, but was very confusing when I started investigating what's wrong with #7479. Briefly, for Solarish platforms pulseaudio doesn't support device list. It just doesn't have means to enumerate/show any hardware devices. But it doesn't mean that it doesn't work for setting basic device properties generally for pulseaudio or for /dev/dsp.

Thanks.

Should I file a different issue about PulseAudio not working on my system?

Actions #5

Updated by Will B over 4 years ago

Should I file a different issue about PulseAudio not working on my system?

Oui ou non?

Anyway, after adding an NVIDIA GTX-610 video card to my system and disabling the integrated Intel graphics, the PulseAudio issue is resolved. PulseAudio now works for Thunderbird and Firefox, as well as other apps like RhythmBox and Totem.

Actions

Also available in: Atom PDF