Project

General

Profile

Actions

Bug #7951

closed

loader: disk_print should open nested partition with disk_open

Added by Toomas Soome about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
bootloader
Start date:
2017-03-08
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The current disk_print() is re-using the open disk structure and to read partition tables, is setting the offset in disk structure "manually". However, after ioctl() updates, this is not enough and instead of hacking around inside disk structure, we should just use disk_open() for nested partition.

The issue is affecting the output of lsdev loader command, causing it to miss details about embedded partitions.

Actions #1

Updated by Electric Monk about 5 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

git commit 0eec6d647c67ffda03b768c8686fedcf218dae1e

commit  0eec6d647c67ffda03b768c8686fedcf218dae1e
Author: Toomas Soome <tsoome@me.com>
Date:   2017-03-21T16:06:00.000Z

    7951 loader: disk_print should open nested partition with disk_open
    Reviewed by: Marcel Telka <marcel@telka.sk>
    Reviewed by: Jason King <jason.brian.king@gmail.com>
    Approved by: Robert Mustacchi <rm@joyent.com>

Actions

Also available in: Atom PDF