Project

General

Profile

Feature #7961

Can wxWidgets be upgraded to v3.0.2 or later for Filezilla build

Added by r a about 4 years ago. Updated about 4 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-03-11
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I have upgraded my default compiler to gcc version 5.4.0 (OpenIndiana 5.4.0-OI-3)

Have been able to build libfilezilla v0.9.1 http://download.filezilla-project.org/libfilezilla/libfilezilla-0.9.1.tar.bz2

$ CXX=g++ CC=gcc ./configure --prefix=/opt/gnu
$ gmake
  1. gmake install

When I attempt to build Filezilla 3.17.0.1 the build process fails because wxWidgets is too old

checking for wxWidgets version >= 3.0.2 (--unicode=yes --universal=no)... no (version 2.8.12 is not new enough)
configure: error:
The requested wxWidgets build couldn't be found.

Also available in: Atom PDF