Project

General

Profile

Actions

Bug #8001

closed

guest virtualbox system dumps core when I attach Host drive DVD-RW with inserted audio CD to it

Added by Alexander Pyhalov about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2017-03-24
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Running Virtualbox 4.3.30 on mid-March OpenIndiana system, guest is yesterday's build of OI.

When I attach host device to the system and it has audio CD in it (or perhaps, just this particular CD), guest system crashes on boot. This is reproducible.
First of all, screen is filled with some read timeouts, then I see the following dump
http://imgur.com/UDg84Nz :

> $C
ffffff0003f739c0 ahci_add_doneq+0x14(ffffff0186dd4cc0, 0, 1)
ffffff0003f73a60 ahci_mop_commands+0x148(ffffff0186dcce40, ffffff0186dd4cc0, 1, 
2, 0, 0, ffffff0000000000)
ffffff0003f73b00 ahci_fatal_error_recovery_handler+0x241(ffffff0186dcce40, 
ffffff0186dd4cc0, ffffff0188057850, 40000000)
ffffff0003f73b60 ahci_events_handler+0xda(ffffff01881353f0)
ffffff0003f73c20 taskq_thread+0x2d0(ffffff0188489c18)
ffffff0003f73c30 thread_start+8()
> ::status
debugging crash dump vmcore.0 (64-bit) from openindiana
operating system: 5.11 illumos-7909625 (i86pc)
image uuid: 10b698ed-7eca-cc12-ec7b-c55d11390c86
panic message: 
BAD TRAP: type=e (#pf Page fault) rp=ffffff0003f738b0 addr=40 occurred in module
 "ahci" due to a NULL pointer dereference
dump content: kernel pages only

$ uname -a 
SunOS openindiana 5.11 illumos-7909625 i86pc i386 i86pc Solaris

This doeesn't happen, when I attach empty cdrom or cdrom witth inserted mp3 CD.


Related issues

Is duplicate of illumos gate - Bug #7075: ahci: NULL pointer dereference in ahci_add_doneq()New2016-06-06

Actions
Actions #1

Updated by Marcel Telka about 4 years ago

This is very likely a duplicate of #7075.

Actions #2

Updated by Marcel Telka about 4 years ago

  • Is duplicate of Bug #7075: ahci: NULL pointer dereference in ahci_add_doneq() added
Actions #3

Updated by Marcel Telka about 4 years ago

  • Category set to driver - device drivers
  • Status changed from New to Closed
Actions

Also available in: Atom PDF