Project

General

Profile

Actions

Bug #8032

closed

libtnfctl: add EAGAIN to prb_status_t enum list

Added by Toomas Soome about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
lib - userland libraries
Start date:
2017-04-05
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Medium
Tags:
Gerrit CR:

Description

From gcc-6 build:

../prb_child.c:272:2: error: case value '11' not in enumerated type 'prb_status_t {aka enum prb_status}' [-Werror=switch]
  case EAGAIN:
  ^~~~
cc1: all warnings being treated as errors
../open.c: In function 'step_to_end_of_exec':
../open.c:457:2: error: case value '11' not in enumerated type 'prb_status_t {aka enum prb_status}' [-Werror=switch]
  case EAGAIN:
  ^~~~
cc1: all warnings being treated as errors

Subtasks 1 (0 open1 closed)

Bug #8039: libtnfctl: prb_child.c cstyle cleanupClosedToomas Soome2017-04-05

Actions
Actions #1

Updated by Toomas Soome about 5 years ago

  • Subject changed from libtnfctl: use int instead of prb_status_t for status check to libtnfctl: add EAGAIN to prb_status_t enum list

The problem is about prb_status enum missing the EAGAIN value, so we need to include this value in enum.

Actions #2

Updated by Electric Monk about 5 years ago

  • Status changed from In Progress to Closed

git commit 8e1c282f21a1ca9422d0f1c9922b6679bb245185

commit  8e1c282f21a1ca9422d0f1c9922b6679bb245185
Author: Toomas Soome <tsoome@me.com>
Date:   2017-04-25T23:39:38.000Z

    8032 libtnfctl: add EAGAIN to prb_status_t enum list
    8039 libtnfctl: prb_child.c cstyle cleanup
    Reviewed by: Marcel Telka <marcel@telka.sk>
    Approved by: Robert Mustacchi <rm@joyent.com>

Actions

Also available in: Atom PDF