Project

General

Profile

Actions

Bug #8053

closed

illumos won't boot on Xen 4.8 HVM in DomU because o APIC

Added by Michal Nowak almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2017-04-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

illlumos (e.g. current OpenIndiana hipster) stuck booting on Xen 4.8 HVM in DomU if APIC is enabled, with APIC removed from the VM guest (e.g. remove <apic/> from <features> in guest's libvirt XML description) it boots fine.

Traces with APIC present and w/o APIC attached.


Files

apic (1.26 KB) apic APIC present Michal Nowak, 2017-04-10 03:49 PM
noapic (4.51 KB) noapic APIC missing Michal Nowak, 2017-04-10 03:49 PM
illumos_hvm+APIC.log (6.55 KB) illumos_hvm+APIC.log kernel trace Michal Nowak, 2017-04-10 03:49 PM

Related issues

Is duplicate of illumos gate - Bug #3605: Xen HVM hangs during boot if apix is enabledIn Progress2013-03-02

Actions
Actions #1

Updated by Igor Kozhukhov almost 5 years ago

illumos has old xen-3.4 updates and need some work on xen-4.x update - with apic too

Actions #2

Updated by Yuri Pankov almost 5 years ago

Likely the same as #3605?

Actions #3

Updated by Michal Nowak over 4 years ago

  • Is duplicate of Bug #3605: Xen HVM hangs during boot if apix is enabled added
Actions #4

Updated by Michal Nowak over 4 years ago

Yuri Pankov wrote:

Likely the same as #3605?

Exactly. Please close (don't have the right to do so myself apparently).

Actions #5

Updated by Joshua M. Clulow over 4 years ago

  • Status changed from New to Closed
  • Tags deleted (needs-triage)
Actions

Also available in: Atom PDF