Project

General

Profile

Bug #8056

zfs send size estimate is inaccurate for some zvols

Added by Serapheim Dimitropoulos over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2017-04-11
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

The send size estimate for a zvol can be too low, if the size of the record headers (dmu_replay_record_t's) is a significant portion of the size.
This is typically the case when the data is highly compressible, especially with embedded blocks.

The problem is that dmu_adjust_send_estimate_for_indirects() assumes that blocks are the size of the "recordsize" property (128KB).
However, for zvols, the blocks are the size of the "volblocksize" property (8KB). Therefore, we estimate that there will be 16x less record headers than there really will be.

History

#1

Updated by Electric Monk over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 0255edcc85fc0cd1dda0e49bcd52eb66c06a1b16

commit  0255edcc85fc0cd1dda0e49bcd52eb66c06a1b16
Author: Paul Dagnelie <pcd@delphix.com>
Date:   2017-06-08T01:57:05.000Z

    8056 zfs send size estimate is inaccurate for some zvols
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Reviewed by: Pavel Zakharov <pavel.zakharov@delphix.com>
    Approved by: Robert Mustacchi <rm@joyent.com>

Also available in: Atom PDF