Project

General

Profile

Bug #807

Trivial ACEs missing delete

Added by Albert Lee over 8 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
kernel
Start date:
2011-03-12
Due date:
% Done:

50%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Windows CIFS clients do not allow a file to be deleted without at least one of the following:
  • An allow ACE with delete (can be inherited) in the file's ACL
  • An allow ACE on the ACL of the file's parent directory with delete_child

Write permission on a directory is sufficient to allow deleting its children in the Unix permission model. However, trivial ACEs generated from modes with write permission do not include delete_child, so Windows is unhappy.


Related issues

Related to illumos gate - Feature #742: Resurrect the ZFS "aclmode" propertyResolved2011-02-18

Actions
Related to illumos gate - Bug #3528: setting permission with chmod kills delete_child permission on owner aclClosed2013-02-05

Actions
Is duplicate of illumos gate - Bug #6762: POSIX write should imply DELETE_CHILD on directories - and some additional considerationsClosed2016-03-19

Actions

History

#1

Updated by Gordon Ross over 6 years ago

  • Assignee changed from Albert Lee to Kevin Crowe
  • % Done changed from 0 to 50
  • Difficulty set to Medium
  • Tags set to needs-triage
#2

Updated by Joshua M. Clulow about 3 years ago

  • Assignee deleted (Kevin Crowe)
#3

Updated by Yuri Pankov about 3 years ago

  • Status changed from In Progress to Feedback

This should be fixed in #6762.

#4

Updated by Yuri Pankov about 3 years ago

  • Status changed from Feedback to Closed

Closing as fixed, please reopen if it's still a problem.

#5

Updated by Yuri Pankov about 3 years ago

  • Is duplicate of Bug #6762: POSIX write should imply DELETE_CHILD on directories - and some additional considerations added

Also available in: Atom PDF