Project

General

Profile

Bug #8087

text-install: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)

Added by Michal Nowak over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
2017-04-21
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

OI MATE installation via text installer fails when Europe is selected in TZ screen:

2017-04-21 09:04:05,261 - INFO    : text-install:120 **** START ****
2017-04-21 09:04:20,657 - ERROR   : fdisk_partitions.py:126 No partitions were selected. Continuing.
2017-04-21 09:04:25,878 - INFO    : network_type.py:174 Configuring NIC as: automatic
2017-04-21 09:04:43,988 - ERROR   : text-install:267 Install Profile:
Disk Info (c4t0d0):
Size: 50.0gb
NIC None:
Type: automatic
System Info:
Hostname: gaiwan
TZ: Europe - None - None
Time Offset: 0
Keyboard: None
Locale: None
None
2017-04-21 09:04:43,989 - ERROR   : text-install:268 Traceback (most recent call last):
  File "/usr/bin/text-install", line 231, in <module>
    SCREEN = SCREEN.show(INSTALL_PROFILE)
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/base_screen.py", line 124, in show
    self._show()
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/timezone.py", line 147, in _show
    text=timezone, data_obj=timezone)
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/list_item.py", line 60, in __init__
    self.set_text(text, centered)
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/list_item.py", line 69, in set_text
    centered=centered)
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/inner_window.py", line 342, in add_text
    text = fit_text_truncate(text, max_chars)
  File "/usr/lib/python2.7/vendor-packages/osol_install/text_install/i18n.py", line 93, in fit_text_truncate
    text = text.decode(get_encoding())
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)

2017-04-21 09:04:43,989 - INFO    : text-install:99 **** END ****

The same scenario works fine in Text install medium; picking GMT works fine as well. Maybe some locale/TZ data are missing or misplaced?

I used this medium http://buildzone.oi-build.r61.net/test-isos-2017-03-13/ but it happens with latest Hipster snapshot as well. Screencast attached. OI is under Linux QEMU 2.9.0 with KVM on.

History

#1

Updated by Alexander Pyhalov over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to Alexander Pyhalov

The issue is that /usr/share/lib/zoneinfo/tab/country.tab contains non-ascii (UTF-8) data, which
a) can't be displayed in C locale, used by current text installer in GUI environment;
b) should be handled properly in text installer to be displayed in en_US.UTF-8.

#3

Updated by Alexander Pyhalov over 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF