Project

General

Profile

Bug #8107

Bad trap in "genunix" due to NULL pointer dereference on RAIDZ

Added by Michal Nowak almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2017-04-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I built OpenIndiana image on April 23rd with illumos f289ce6eb0 (distro constructor prescript attached). Installed the system to RAIDZ with three 20 GB virtio disks under Linux KVM. On first boot kernel crashes with "bad trap" after smf service descriptions are loaded, restart follows, then the same crash again.

The same scenario with alp's OI snapshot from March 13th boots from RAIDZ just fine. Installation to mirror or single disk works fine.

Screenshots from kernel debugger attached.


Files

slim_text_X86.xml (17.1 KB) slim_text_X86.xml Michal Nowak, 2017-04-25 04:41 PM
qemu-zpool-1.png (11.8 KB) qemu-zpool-1.png Michal Nowak, 2017-04-25 05:00 PM
qemu-zpool-2.png (13.5 KB) qemu-zpool-2.png Michal Nowak, 2017-04-25 05:00 PM
qemu-zpool-stack.png (13.8 KB) qemu-zpool-stack.png Michal Nowak, 2017-04-25 05:00 PM
qemu-zpool-status.png (12.9 KB) qemu-zpool-status.png Michal Nowak, 2017-04-25 05:00 PM

Related issues

Is duplicate of illumos gate - Bug #8100: 8021 seems to cause random BAD TRAP: type=d (#gp General protection)Closed2017-04-24

Actions

History

#1

Updated by Igor Kozhukhov almost 3 years ago

  • Related to Bug #8100: 8021 seems to cause random BAD TRAP: type=d (#gp General protection) added
#2

Updated by Michal Nowak almost 3 years ago

  • Related to deleted (Bug #8100: 8021 seems to cause random BAD TRAP: type=d (#gp General protection))
#3

Updated by Michal Nowak almost 3 years ago

  • Is duplicate of Bug #8100: 8021 seems to cause random BAD TRAP: type=d (#gp General protection) added
#4

Updated by Michal Nowak almost 3 years ago

It's duplicate. Please close (don't have the right to do so myself apparently).

#5

Updated by Marcel Telka almost 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF