Project

General

Profile

Bug #8124

sysutils/ipmitool build stops with a compiler options error

Added by Gary Mills over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2017-04-28
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

A build of the sysutils/ipmitool component with GCC on SPARC hardware failed with the following error:

Compiler or options invalid for pre-UNIX 03 X/Open applications and pre-2001 POSIX applications

A patch to configure.ac that changes the line:

CFLAGS="$CFLAGS -Wall -Wextra -std=gnu99 -pedantic -Wformat -Wformat-nonliteral"

into:

CFLAGS="$CFLAGS -Wall -Wextra -std=gnu89 -Wformat -Wformat-nonliteral"

fixes the problem.

History

#1

Updated by Gary Mills over 2 years ago

  • Subject changed from sysutils/ipmitool build with GCC -pedantic is too strict to sysutils/ipmitool build stops with a compiler options error

The cause turned out to be completely different from what I initially suspected. The patch to configure.ac is no longer required. Two of the source files contain the line:

#define _XOPEN_SOURCE 700

Changing these to 600 with a patch allowed the build to complete. Clearly, the source does not include any 700-level features, because it compiled with 600.

Also available in: Atom PDF