Project

General

Profile

Actions

Bug #8159

closed

Build of several components stops because of unreadable source files

Added by Gary Mills about 7 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2017-05-05
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

A build of the gnome-netstatus component of oi-userland stops with the error message:

cp: cannot open `.../wifi_info.c.~1~' for reading: Permission denied

Other components have the same problem: desktop/gnome2/gnome-power-manager x11/xorg-server runtime/openjdk-8 . It's caused by files created during the patching step with 000 permissions. It only happens when the component Makefile contains lines like:

COMPONENT_PRE_CONFIGURE_ACTION = (cp -r ...)

The solution is to make the files readable before copying them, like this:

COMPONENT_PRE_CONFIGURE_ACTION = ($(CHMOD) -R u+r $(SOURCE_DIR) && ...)

Actions #1

Updated by Marcel Telka 7 months ago

  • Status changed from Feedback to Closed

This is no longer a problem. Both gnome-netstatus and desktop/gnome2/gnome-power-manager were removed. x11/xorg-server and runtime/openjdk-8 builds properly.

Actions

Also available in: Atom PDF