Project

General

Profile

Bug #8178

Failed to execute child process "/usr/sbin/iotrace" (Permission denied)

Added by Michal Nowak over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2017-05-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I found this in warning in dmesg of OI 2017.04 Live USB medium:

mate-session: Could not launch application 'iotrace.desktop':
Unable to start application: failed to execute child process "/usr/sbin/iotrace" (Permission denied)

Perhaps because /usr/sbin/iotrace shell script is missing executable bits.


Files

OI-warnings.jpg (305 KB) OI-warnings.jpg Michal Nowak, 2017-05-07 08:48 PM

History

#1

Updated by Nikola M. over 2 years ago

Hello, pkg search -rp gives that iotrace is part of the system/install/media/internal package, pkg info -r says "Services used by the installation media" in the description, pkg contents -r says that it is a package specific to jack/jack user, for use on Live media, so it is not ,so to say, OI post-installation bug, once when installed on disk since it is package only on Live media.

Surely someone else could send explanation why that message is in the log.
'jack' user is supposedly unprivileged user, but can use sudo/pfexec to elevate right if booted form live media, unless 'jack' lacks some rights for RoleBasedAcessControl (RBAC) in /etc/user_attr .
Try issuing iotrace with pfexec/sudo.but I suppose that does not stop Live media to be functional.

#2

Updated by Michal Nowak over 2 years ago

Thanks, but I don't want to run that script on my own. My only concern is that something somewhere tried to execute it, and failed.

#3

Updated by Nikola M. over 2 years ago

Can you please install Openindiana to the disk and then try to reproduce the bug,
so to exclude that it is only about live media, that is not normal installed environment.
Thanks

#4

Updated by Alexander Pyhalov over 2 years ago

  • Status changed from New to Resolved
  • Assignee set to Michal Nowak

Also available in: Atom PDF