Project

General

Profile

Bug #8179

system-config-printer-applet is missing, but attempted to be executed by MATE

Added by Michal Nowak over 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2017-05-07
Due date:
2017-11-15
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
mate

Description

On OI 207.04 USB Live medium I see in dmesg:

Could not launch application 'print-aplet.desktop': Unable to start application: Failed to execute child process "/usr/lib/system-config-printer/system-config-printer-applet" (No such file or directory)


Files

OI-warnings.jpg (305 KB) OI-warnings.jpg Michal Nowak, 2017-05-07 08:54 PM
system-config-printer-output.txt (2.13 KB) system-config-printer-output.txt Nikola M., 2017-05-08 03:00 PM

History

#1

Updated by Nikola M. over 2 years ago

Hi, see in the meantime, if you can use 'Manage printing' icon in Applications>System Tools ,
that opens http://localhost:631/ - CUPS setting web page.

Btw, I can open 'system-config-printer' by issuing it in a mate-terminal window. I also have not uninstalled GNOME still (I added MATE on top and updated some time ago). with attached output to this message.

#2

Updated by Nikola M. over 2 years ago

Hi,
Can you please try to reproduce bug on Openindiana installed on disk,
since Live media is not regular working install environment.
Thanks!

#3

Updated by Ken Mays about 2 years ago

Tested: 2017.04 snapshot Live DVD

The print manager applet appears under System->Administration->Print Manager
This brings up the system-config-printer GUI.

Some cleanup needed as I get:
"Aug 26 07:55:53 openindiana mate-session3046: [ID 702911 daemon.warning] WARNING: Could not launch application 'print-applet.desktop': Unable to start application: Failed to execute child process "/usr/lib/system-config-printer/system-config-printer-applet" (No such file or directory)"

Note: This is where it belongs:
jack@openindiana:/jack$ ls /usr/bin/system-config-printer-applet
ls: cannot access '/usr/bin/system-config-printer-applet': No such file or directory

#4

Updated by Michal Nowak almost 2 years ago

This was fixed with https://github.com/OpenIndiana/oi-userland/commit/a767f48c8fbe0de72ff2cce8fa729b94ca817a50. I verified that with a newly built image. Please close this.

#5

Updated by Aurélien Larcher almost 2 years ago

  • Due date set to 2017-11-15
  • Status changed from New to Resolved
  • Tags changed from needs-triage to mate

Also available in: Atom PDF