Project

General

Profile

Actions

Bug #8252

closed

developer/libtool always invokes /usr/bin/automake

Added by Gary Mills over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2017-05-19
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

A build of the developer/libtool component of oi-userland always invokes the fully-qualified name /usr/bin/automake, instead of searching the PATH. This behavior is correct when /usr/bin/automake is installed from a hipster package, but can be incorrect when a newer automake is installed someplace else in the PATH.

The cause is this line in the component Makefile:

COMPONENT_PREP_ACTION = (cd $(@D) ; env AUTOMAKE=/usr/bin/automake ./bootstrap)

The solution is simply to change it to ``env AUTOMAKE=automake'' instead.

Actions #1

Updated by Alexander Pyhalov over 5 years ago

It's default, perhaps, just remove AUTOMAKE=/usr/bin/automake?

Actions #2

Updated by Gary Mills over 5 years ago

Yes, it was the default. I've removed the entire phrase. It still builds as before.

Actions

Also available in: Atom PDF