Project

General

Profile

Bug #8253

zdb -l doesn't show L2, L3 labels

Added by Alexander Stetsenko over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2017-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
zfs, zdb

Description

zdb shows labels L0, L1, but L2, L3 empty.

The bug was introduced by this changes:
https://github.com/illumos/illumos-gate/commit/64723e361134b2a2c45341334174f9d34002f8d0

The reason is open64 call was moved bellow stat64 one, as result stat64 returns zero in st_size.
Because of 0 size vdev_label_offset call returns invalid value and zdb failed to read labels L2, L3

The fix:
Moving open64 call above stat64 (as it was before the change) fixes the issue.


Related issues

Is duplicate of illumos gate - Bug #8108: zdb -l fails to read labels 2 and 3Closed2017-04-25

Actions

History

#2

Updated by Yuri Pankov over 2 years ago

  • Is duplicate of Bug #8108: zdb -l fails to read labels 2 and 3 added
#3

Updated by Electric Monk over 2 years ago

  • Status changed from New to Closed

git commit 22c8b9583d07895c16549075a53668d7bc988cf3

commit  22c8b9583d07895c16549075a53668d7bc988cf3
Author: Yuri Pankov <yuri.pankov@nexenta.com>
Date:   2017-06-08T01:57:55.000Z

    8108 zdb -l fails to read labels 2 and 3
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Igor Kozhukhov <igor@dilos.org>
    Reviewed by: Andrew Stormont <andyjstormont@gmail.com>
    Approved by: Robert Mustacchi <rm@joyent.com>

Also available in: Atom PDF