Project

General

Profile

Actions

Bug #8312

closed

rc3.d script does not start on boot

Added by Nikola M. over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
OS/Net (Kernel and Userland)
Target version:
-
Start date:
2017-06-04
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

I have put a script into /etc/rc3.d/ , named Swon, to bring up Wireless connection to internet on machine boot:
( $ ls l /etc/rc3.d/Swon
-rwxr-xr-
1 root root 37 Aug 4 2016 /etc/rc3.d/Swon
$ cat /etc/rc3.d/Swon
dladm connect-wifi -e AP -k AP ath0 )

But since recent update (currently illumos-dea5823132 , osnet-incorporation 0.5.11-2017.0.0.16444 , userland-incorporation 0.5.11-2017.0.0.9053 ) ,
seems like script is not executed and that wireless connection is not made, leaving machine offline after boot.

Reporting the bug to see if it is OI-related, or as it seems, illumos-related.
As seen, the script is executable and used to work fine on boot, since recently.

Actions #1

Updated by Nikola M. over 4 years ago

I think this also could be an local/temporary issue and can't reproduce it regularly or after update.

I ask this bug to be resolved as invalid , because can't be reproduced in regular fashion.
Sorry for the inconvenience.

Actions #2

Updated by Alexander Pyhalov over 4 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF