Project

General

Profile

Bug #8407

/hipster postfix problems

Added by Predrag Zečević over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-06-17
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,
tried to use latest OI postfix: 3.1.6 (https://github.com/OpenIndiana/oi-userland/pull/3283) and have faced with problems...
NOTE: was using postfix 3.1.4 from http://sfe.opencsw.org/localhostoih/en/index.shtml repository - that was running OK without any modifications

In order to make this version working I had to:
a) change /etc/postfix/main.cf

sendmail_path = /usr/lib/postfix/sendmail
newaliases_path = /usr/lib/postfix/sendmail
mailq_path = /usr/lib/postfix/sendmail

b) create symlinks on filesystem (for other programs, like mutt):
$ pfexec ln -s /usr/lib/postfix/sendmail /usr/lib/sendmail
$ pfexec ln -s /usr/lib/postfix/sendmail /usr/sbin/newaliases
$ pfexec ln -s /usr/lib/postfix/sendmail /usr/bin/mailq

c) not sure if this is important, but added:
$ pfexec pkg set-mediator -I postfix -V 3.1.6 mta

I do not use sendmail since long time ago, and with changes above I have managed to use postfix mta

$ svcs -H -o state sendmail
disabled

$ svcs -a | grep -E "sendmail|postfix|smtp|mta" 
disabled       Jun_16   svc:/network/smtp:sendmail
disabled       Jun_16   svc:/network/sendmail-client:default
online          9:03:37 svc:/network/smtp:postfix

Moreover, mailwrapper is sendmail centric...
$ pfexec pkg fix system/network/mailwrapper
No updates necessary for this image.

$ pkg contents pkg:/system/network/mailwrapper
PATH
etc
etc/mail
etc/mailer.conf
usr/bin
usr/bin/mailq
usr/lib
usr/lib/mailwrapper
usr/lib/sendmail
usr/sbin
usr/sbin/newaliases
usr/sbin/sendmail
usr/share/man
usr/share/man/man1m
usr/share/man/man1m/mailwrapper.1m
usr/share/man/man4
usr/share/man/man4/mailer.conf.4

$ cat /etc/mailer.conf
#
# This file configures mailwrapper(1M).
# For details see mailer.conf(4).
# The following configuration is correct for sendmail(1M).
#

sendmail        /usr/lib/smtp/sendmail/sendmail
newaliases      /usr/lib/smtp/sendmail/sendmail
mailq           /usr/lib/smtp/sendmail/mailq

I guess package should cover steps a) - c) when installing - or - for step b) to fix mailwrapper setup ...

Regards

History

#1

Updated by Adam Števko over 2 years ago

Postfix works:

You can see that we ship mta mediator. It set to postfix, it works as intended:
https://github.com/OpenIndiana/oi-userland/blob/oi/hipster/components/mail/postfix/postfix.p5m#L94

vagrant@openindiana:~$ ls -l /usr/lib/sendmail 
lrwxrwxrwx   1 root     root          11 May 19 00:19 /usr/lib/sendmail -> mailwrapper
vagrant@openindiana:~$ pfexec pkg mediator
MEDIATOR    VER. SRC. VERSION IMPL. SRC. IMPLEMENTATION
apache      system    2.4     system     
ftpd        system            system     proftpd
java        vendor    8       vendor     
mta         system            system     mailwrapper
mysql       system    5.5     system     mariadb
openssl     vendor            vendor     default
perl        vendor    5.22    vendor     
python      vendor    2.7     vendor     
system-perl vendor    5.22    vendor     
vagrant@openindiana:~# pkg set-mediator -I postfix mta
            Packages to change:   3
           Mediators to change:   1
       Create boot environment:  No
Create backup boot environment: Yes
PHASE                                          ITEMS
Removing old actions                             2/2
Updating modified actions                        6/6
Updating package state database                 Done 
Updating package cache                           0/0 
Updating image state                            Done 
Creating fast lookup database                   Done 
vagrant@openindiana:~$ ls -l /usr/lib/sendmail 
lrwxrwxrwx   1 root     root          16 Jun 19 20:51 /usr/lib/sendmail -> postfix/sendmail

If this is unclear, maybe you could send a pr to oi-docs? That would be appreciated.

#2

Updated by Adam Števko over 2 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF