Project

General

Profile

Actions

Feature #8411

closed

Build should warn when linking against libraries outside proto area

Added by Andrew Stormont over 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2017-06-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

With obvious exceptions for the native stuff and the libraries that illumos-gate doesn't provide, such as libxml2, zlib, glib, etc.


Related issues

Related to illumos gate - Bug #12217: add ld assert-deflib and guidance to gate buildClosedToomas Soome

Actions
Has duplicate illumos gate - Feature #9852: enable ld(1) guidance and deflib assertions for the illumos buildClosedRich Lowe2018-09-19

Actions
Actions #2

Updated by Andrew Stormont about 3 years ago

  • Has duplicate Feature #9852: enable ld(1) guidance and deflib assertions for the illumos build added
Actions #3

Updated by Andrew Stormont almost 2 years ago

  • Related to Bug #12217: add ld assert-deflib and guidance to gate build added
Actions #4

Updated by Toomas Soome over 1 year ago

  • Status changed from In Progress to Closed

Duplicate of 12217

Actions

Also available in: Atom PDF