Project

General

Profile

Bug #8420

loader.efi: EFI_MEMORY_DESCRIPTOR and EFI_BLOCK_IO_MEDIA need padding

Added by Toomas Soome over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
bootloader
Start date:
2017-06-22
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The problem is revealed in 32-bit version; unfortunately the specification is not really too clear either. Fix confirmed with 32-bit UEFI and qemu, and verified no regression with 64-bit UEFI.

See also: https://svnweb.freebsd.org/base?view=revision&revision=320234, note the block io media issue is not yet addressed in FreeBSD.

Also available in: Atom PDF