Project

General

Profile

Bug #8512

libstand won't build with GCC 7.1

Added by Andrew Stormont about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2017-07-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

GCC 7.1 generates references to __divmoddi4 and __udivmoddi4 which need to be supplied by libstand.


Related issues

Is duplicate of illumos gate - Bug #8500: loader: need __divmoddi4 and __udivmoddi4Closed2017-07-15

Actions

History

#2

Updated by Yuri Pankov about 2 years ago

This looks like a duplicate of #8500.

#3

Updated by Andrew Stormont about 2 years ago

  • Is duplicate of Bug #8500: loader: need __divmoddi4 and __udivmoddi4 added
#4

Updated by Electric Monk almost 2 years ago

  • Status changed from New to Closed

git commit d8b4f927017620c0d78dc3b4fd238ed58bbb4b42

commit  d8b4f927017620c0d78dc3b4fd238ed58bbb4b42
Author: Toomas Soome <tsoome@me.com>
Date:   2017-10-16T13:35:10.000Z

    8500 loader: need __divmoddi4 and __udivmoddi4
    Reviewed by: Dan McDonald <danmcd@joyent.com>
    Reviewed by: Yuri Pankov <yuripv@gmx.com>
    Reviewed by: Igor Kozhukhov <igor@dilos.org>
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF