Project

General

Profile

Bug #8533

ldap client causes smbd to crash / hang

Added by Oli W about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
-
Category:
cifs - CIFS server and client
Start date:
2017-07-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

we are running omnios as a zfs storage server:

SunOS omnios01 5.11 omnios-r151022-f9693432c2 i86pc i386 i86pc

The smbd service keeps crashing as soon as we activate ldap client.

/var/svc/log/network-smb-server:default.log:

@ Mon Jul 24 12:29:04 2017
smbd.info: smbd_dc_update: a.space.corp: located gedaspw02.a.space.corp
smbd_localtime_monitor: online
[ Jul 24 12:44:17 Stopping because process dumped core. ]
[ Jul 24 12:44:17 Executing stop method (:kill). ]
[ Jul 24 12:45:17 Method or service exit timed out. Killing contract 84623. ]
[ Jul 24 12:45:18 Method or service exit timed out. Killing contract 84623. ]
[ Jul 24 12:45:19 Method or service exit timed out. Killing contract 84623. ]
[ Jul 24 12:45:20 Method or service exit timed out. Killing contract 84623. ]

The only possible workaround is to deactivate ldap client and reboot the OmniOS VM, which is not good because we need it.

We also have a nexenta system and nexenta support was able to fix the issue for us. I'm not sure what problem they found but they provided us a fixed nss_ldap.so.1 file.

Best Regards,
Oliver


Related issues

Is duplicate of illumos gate - Bug #8543: nss_ldap crashes handling a group with no gidnumber attributeClosed2017-07-27

Actions

History

#1

Updated by Yuri Pankov about 2 years ago

  • Status changed from New to Closed

duplicates #8543, review is out for that one.

#2

Updated by Yuri Pankov about 2 years ago

  • Is duplicate of Bug #8543: nss_ldap crashes handling a group with no gidnumber attribute added

Also available in: Atom PDF