Project

General

Profile

Actions

Feature #8587

closed

svc:/network/routing/route:default usually is not needed nowadays

Added by Alexander Pyhalov almost 5 years ago. Updated 4 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2017-08-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

Assigning routes statically or getting them via DHCP is a much more common case today than getting them via RIP or IRDP. There's little to no use in having routed enabled by default nowadays.


Related issues

Related to illumos gate - Bug #14641: Split ndpd from routing packageNew

Actions
Related to illumos gate - Feature #14644: Rename network/routing to dynamic-routingNew

Actions
Is duplicate of illumos gate - Bug #14006: ipv4-routing should not be enabled by defaultNew

Actions
Actions #1

Updated by C Fraire almost 5 years ago

I have a patch to net-routing-setup to also examine /etc/inet/static_routes early when determining defrouters. This way, default static routes will also cause net-routing-setup to disable routeadm/default-ipv4-routing.

net-routing-setup already iterates through /etc/inet/static_routes as the last stage in its processing for "Adding persistent routes:", so this could not be considered a major change to the script.

Actions #2

Updated by Gordon Ross over 4 years ago

I've run into this annoyance too. If one uses "route -p ..." to setup a default route,
at some later date (i.e. after some sleep/resume cycles on a laptop) one may
discover that in.routed has removed the static route.

Note, "route -p ..." stores the persistent state in /etc/inet/static_routes.

Work around: create /etc/defaultrouter instead.

Actions #3

Updated by David Stes 4 months ago

The routing package could perhaps be removed from:

oi-userland/components/meta-packages/install-types/includes/minimal

Currently (as of 2022) it is in the minimal group. The minimal server install currently includes:


depend type=require fmri=system/network/routing

I have tested that it is fairly easy to uninstall the package using


pkg uninstall -v routing

(or if necessary:


pkg uninstall mate_install
pkg uninstall -v routing

In the latter case it simply removes the group mate_install (without actually uninstalling MATE nor installing any apps , nor uninstalling the desktop itself)

Uninstalling the routing package uninstalls stuff like

usr/lib/inet/in.ndpd
usr/lib/inet/in.ripngd
usr/sbin/in.rdisc
usr/sbin/in.routed
usr/sbin/rtquery

perhaps IPV6 in.ndpd could be moved into a separate package instead of routing.

I'll open a separate feature request for that
( in.ndpd - daemon for IPv6 autoconfiguration )

Actions #4

Updated by David Stes 4 months ago

  • Has duplicate Bug #14006: ipv4-routing should not be enabled by default added
Actions #5

Updated by David Stes 4 months ago

  • Related to Bug #14641: Split ndpd from routing package added
Actions #6

Updated by David Stes 4 months ago

I've also tested that if you do:


pkg uninstall mate_install
pkg uninstall routing

if you later do a

pkg update -v -f

it does not reinstall routing (in a new update). As long as you don't reinstall the mate_install group of course.

Updates of what was installed by the mate_install are still going to happen.

Actions #7

Updated by Joshua M. Clulow 4 months ago

  • Status changed from New to Duplicate

This is indeed effectively a duplicate of #14006.

Actions #8

Updated by Joshua M. Clulow 4 months ago

  • Has duplicate deleted (Bug #14006: ipv4-routing should not be enabled by default)
Actions #9

Updated by Joshua M. Clulow 4 months ago

  • Is duplicate of Bug #14006: ipv4-routing should not be enabled by default added
Actions #10

Updated by David Stes 4 months ago

  • Related to Feature #14644: Rename network/routing to dynamic-routing added
Actions

Also available in: Atom PDF