Project

General

Profile

Bug #8616

ld has trouble parsing -z options specified with -Wl

Added by Andrew Stormont over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Start date:
2017-09-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The -Wl flag is supposed to be a way to pass options to the linker, indirectly via the compiler driver (e.g. gcc), but seeing as buggy build systems often pass it to ld support for it exists directly in the linker; the problem is support isn't good enough. The linker chokes on arguments in the form of -Wl,-z,assert-deflib (which is perfectly valid) because it's caught out by the second comma.

#2

Updated by Electric Monk over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 202ca9ae460faf1825ede303c46abd4e1f6cee28

commit  202ca9ae460faf1825ede303c46abd4e1f6cee28
Author: Andrew Stormont <astormont@racktopsystems.com>
Date:   2017-09-07T18:14:48.000Z

    8616 ld has trouble parsing -z options specified with -Wl
    Reviewed by: Toomas Soome <tsoome@me.com>
    Reviewed by: Yuri Pankov <yuripv@gmx.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF