Project

General

Profile

Bug #8620

pcplusmp shouldn't support x2APIC mode

Added by Hans Rosenfeld about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2017-09-07
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

We are currently in the weird situation to have two platform modules dealing with APIC and x2APIC, namely pcplusmp and apix. Initially there was only pcplusmp that handled the APIC. Then support for x2APIC was added to pcplusmp. A little later a new module apix was introduced to deal with systems supporting x2APIC in both legacy APIC and x2APIC modes. Ever since then all systems supporting x2APIC were using apix, not pcplusmp.

The two modules share a fair bit of code, which isn't surprising as both support the legacy APIC mode. But there really is no reason for pcplusmp to have the ability to work in x2APIC mode. It's relatively easy to garbage-collect the x2APIC support from pcplusmp by moving a few pieces of code around with no functional changes.

History

#1

Updated by Hans Rosenfeld about 2 years ago

Webrev: https://grumpf.hope-2000.org/illumos-8620/

I have tested this change by using it on a few systems:
  • I have an AMD family 0x10 system that does not support x2apic, so it's using the pcplusmp module. There were no problems with the updated pcplusmp module, I saw no warnings in the log and the kmdb ::interrupts output didn't change significantly.
  • Another system I tested on is a Fujitsu Primergy TX150S8 which uses the apix module. I wasn't able to see any regressions there either. My workstations also uses apix and has x2apic enabled by default, and I didn't notice any unexpected behavior their, too.

The change also has been in illumos-joyent since May or so.

#2

Updated by Electric Monk about 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 583cd3308017d0e5a17e7164fbee4c20ed04b165

commit  583cd3308017d0e5a17e7164fbee4c20ed04b165
Author: Hans Rosenfeld <hans.rosenfeld@joyent.com>
Date:   2017-09-20T18:35:31.000Z

    8620 pcplusmp shouldn't support x2APIC mode
    Reviewed by: Robert Mustacchi <rm@joyent.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF