Project

General

Profile

Bug #8697

cmd/acpi: '_AcpiModuleName' defined but not used

Added by Toomas Soome over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
cmd - userland programs
Start date:
2017-10-03
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

Issue revealed by gcc 6 build. The problem is about the OS specific setup in acsolaris.h.

    In file included from /code/illumos-gate/usr/src/uts/intel/sys/acpi/acpi.h:61:0,
                     from utdebug.c:46:
    /code/illumos-gate/usr/src/uts/intel/sys/acpi/acoutput.h:212:75: error: '_AcpiModuleName' defined but not used [-Werror=unused-const-variable=]
     #define ACPI_MODULE_NAME(Name)          static const char ACPI_UNUSED_VAR _AcpiModuleName[] = Name;
                                                                               ^
    utdebug.c:51:9: note: in expansion of macro 'ACPI_MODULE_NAME'
             ACPI_MODULE_NAME    ("utdebug")
             ^~~~~~~~~~~~~~~~
    cc1: all warnings being treated as errors

Also available in: Atom PDF