Bug #8705

unsupported 64-bit prefetch memory on pci-pci bridge

Added by Robert Mustacchi 7 months ago. Updated 5 months ago.

Status:ClosedStart date:2017-10-04
Priority:NormalDue date:
Assignee:Robert Mustacchi% Done:

100%

Category:driver - device drivers
Target version:-
Difficulty:Medium Tags:

Description

On certain systems with large numbers of PCI devices, we see notices that look like the following:

messages:2016-12-16T01:54:46.968439+00:00 magma pci_autoconfig: [ID 241636 kern.notice] NOTICE: unsupported 64-bit prefetch memory on pci-pci bridge [128/1/0]
messages:2016-12-16T01:54:46.968446+00:00 magma pci_autoconfig: [ID 241636 kern.notice] NOTICE: unsupported 64-bit prefetch memory on pci-pci bridge [128/2/2]

These stem from us not handling large addresses for PCI bridges and the like. We should clean this up as part of the broader PCI work that's going on in 8702. It ultimately has the same root cause which is that the x86 root nexus driver was copied from SPARC before 64-bit support existed.


Related issues

Related to illumos gate - Bug #8702: PCI addresses with physaddr > 0xffffffff can't be mapped in Closed 2017-10-04

History

#1 Updated by Robert Mustacchi 7 months ago

  • Related to Bug #8702: PCI addresses with physaddr > 0xffffffff can't be mapped in added

#2 Updated by Electric Monk 5 months ago

  • Status changed from New to Closed

git commit 1f0c5e612d8dfd7d1a8f4487cef753357b9909f5

commit  1f0c5e612d8dfd7d1a8f4487cef753357b9909f5
Author: Robert Mustacchi <rm@joyent.com>
Date:   2017-12-04T17:23:22.000Z

    8702 PCI addresses with physaddr > 0xffffffff can't be mapped in
    8703 pci/npe DDI_CTLOPS_REGSIZE should be 64-bit aware
    8704 want OFF_MAX in the kernel
    8705 unsupported 64-bit prefetch memory on pci-pci bridge
    Reviewed by: Patrick Mooney <patrick.mooney@joyent.com>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Reviewed by: Albert Lee <trisk@forkgnu.org>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom