Project

General

Profile

Actions

Bug #8742

closed

potential iscsi panic

Added by Dan McDonald almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
comstar - iSCSI/FC/SAS target
Start date:
2017-10-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Actions #1

Updated by Electric Monk almost 4 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

git commit 2727bb055f7c5df6135eafd90bde85347d04d071

commit  2727bb055f7c5df6135eafd90bde85347d04d071
Author: Tim Kordas <tim.kordas@joyent.com>
Date:   2017-10-27T19:25:33.000Z

    8742 potential iscsi panic
    Reviewed by: Dan McDonald <danmcd@joyent.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Reviewed by: Jerry Jelinek <jerry.jelinek@joyent.com>
    Approved by: Albert Lee <trisk@forkgnu.org>

Actions #2

Updated by Yuri Pankov almost 4 years ago

Is this in any way related to #2867?

Actions #3

Updated by Dan McDonald almost 4 years ago

Yuri Pankov wrote:

Is this in any way related to #2867?

I don't think so, from what little I've been able to extract from archives thus far. (OTOH, it is possible that this fix may make #2867 harder to reproduce.)

Actions #4

Updated by Dan McDonald almost 4 years ago

Upon further review by Tim: the conditions leading to #2867 panics are thwarted completely by the fix for this bug, at least with respect to kernel panics.

I'm therefore going to close #2867 as a duplicate of this.

Actions

Also available in: Atom PDF